Unable to take any payments through Stripe or reconfigure it at all

Our store to Stripe integration has totally stopped working as of today and we can’t get it working. After it was reported from the customers that they were getting an error, we logged into the store.link dashboard and noticed an alert for our stripe account telling us that there was a new integration and it’s “recomended” to change to it, but that the existing would still work, which clearly isn’t true because it broke.

Anyways, we completed the setup for the new integration to Stripe from your store page, now when anyone goes to the “Continue” on the cart in our store, it skips the payment/card options and goes directly to “your order has been processed”. Stripe has no record of the transaction hiting them, and the card number as never prompted for.

We removed and readded the integration, still the same issue.

This is a big issue for us as we are unable to confirm which orders are paid for and which are basically free orders right now. We aren’t sure how to fix this, if it’s a Stripe issue or a Store.Link issue, but it’s all since we applied your new integration, so we think it’s with your company. Please assist ASAP.

UPDATE :: so it seems that when you go through the update integration to the new version, it is creating a second account within stripe instead of using the existing one. This is a large issue because it doesn’t create the API keys or anything when it does this, so payments are just passed through without processing to stripe. When you go into Stripe and select the new/second account that was created with the “setup integration” … it prompts to setup a whole new (3rd) account, which doesn’t link to the one linked within our store.

We went in and deleted the new accounts on stripe since we have everything setup on the very first one. Loged out, deleted the integration from our store page, then refreshed and tried to readd it… now the button just “flashes” and doesn’t do anything. I’m hoping you guys are working on this which is why the button is now broken?

We really need to have the API KEY/TOKEN method brought back so we can use that, or we need some way when setting up the STRIPE integration to simply select the existing account, instead of creating a new one.

Jake … not sure why you deleted your reply if you are having the same issue, we need to make sure they are aware of this. As of right now, there is no resolution that i’m aware of beside turning off your store and losing business, which is what we had to do till they provide a resolution. I don’t even know if they are working on this… I have submitted this post, along with send up multiple emails, with no reply yet. I wish someone would at least tell me they are working on this.


I am sorry you are having an issue with the Stripe Integration.

We recently moved to Stripe Connect to make setting up the account easier and more secure with a step-by-step process. Older methods required manual processes like copying and pasting API keys, which some nontechnical users find difficult.

Anyway, our tech team is working on fixing the issues you faced while using the Connect button. For the time being, we can make the API key method work. Please mail care@store.link, and we will help you set up the API key while we fix Stripe Connect.


We’ve restored the old API key based stripe integration on your store: https://beefobradys.store.link/

Please enable the orders in your store and see if they work as expected.

it’s back to working normally again, thank you.
just a piece of recommendation to avoid this from happening in the future… when you guys re-implement new integration methods, unless the old integration is being sunset by the providers (stripe in this case) can we please leave the old method still in place for a few days as an option to enter it via API key so that if your customers have these issues, we can revert back and report the issue …but then at least we aren’t going for a full day of not being able to take orders from our customers.

Also this whole issue originally came up because when the new integration method to “stripe connect” was added, it broke something with the API method we had which caused it to get POST connect errors. If it wasn’t for that, we wouldn’t have even noticed the issue as our customers weren’t have had a problem and reported it to us.

So it was issues all around, but if the old legacy API key method was still in place that was a backup of the old code that we could have reverted to, this wouldn’t have happened.

I’m glad to see your store is back online :raised_hands:

We actually planned to support stores that are using API keys without sunsetting them. But we recommended switching to connect with an exclamation mark and preventing further editing of the old API key. I suppose you accidentally clicked connect seeing the exclamation mark, and lost the old API key. We have removed the exclamation mark in the dashboard, and stores with API keys will be working as before.

Actually, this is not accurate. The only reason we originally went to the integration page at all was because customers of our were trying to process orders and they were getting an code formating POST error type of message displayed across the top of the store page. I had no reason to login to the store page otherwise. I only saw the exclamation mark “after” the customer was reporting errors. So something was broken prior which caused it to investigate, which lead us to seeing the exclamation, and we only proceeded with this button… not on accident as you assume, but because we were trying to fix why the error was happening on the page in the first place and we assume it was due to the integration change.

Unfortunately i don’t have the original error to report to you, but I can assure you that I have no reason to go in and look for things to change unless they are broken.

Sorry, my assumptions were wrong.

Can you please provide more details on the code formatting error your customers got? Was it only during the checkout process? Are the customers reporting the same issue after you reopened the store now?

Our tech team will be looking into the mentioned issue further.

sorry, but i don’t have the error that they were receiving at the time prior to all this. It was an odd error that popped up on top with http formatted results, but don’t recall what it was.

Since you guys restored the legacy process for us and are using the API key instead of the new method, we haven’t had any issues, so whatever was original causing the errors didn’t return after you guys restored it. everything has been operational since.

1 Like

That’s good to know. If you have any issues, you can post them here or reach us at care@store.link. We are happy to help.

We are thankful to you for being one of our early adopters. We want to perfect our product based on feedback like this.